Support Article
CTI Error After Login into Phone in CPM Phone Portal
SA-29473
Summary
Logging into PegaCall on CISCO UCCE is generating Failure Code 12 errors.
Error Messages
1.Control Failure Conf Message recieved for RetrieveDeviceSnapshot using invoke id [9] failure code [12] peripheral error code [10137] This can be a result of requesting a device snapshot before the device is logged in.
2.The [SnapshotDevicelRequestMessage] request failed. Failure Code [12]
Steps to Reproduce
1. Open the CPM portal.
2. Open the phone toolbar.
3. Log into Phone.
4. Observe the error in the pegacti log.
Root Cause
Cisco UCCE had changed the behavior of their code at some point which does not allow a device to be monitored w/o having an agent logged in.
Resolution
The error can be ignored.
This is related to how the login process works in Pega. During the login process PegaCall does a device snapshot prior to the actual login.
The reason for the failure code 12 is that Cisco will not allow the device snapshot until after the agent is logged in. The logs will show a second login which will succeed.
Published November 15, 2016 - Updated December 2, 2021
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