Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

CTI Phone Control should be anchored with CPM 7.1.3

SA-15352

Summary



In CPM Interaction portal, CTI phone controller scrolls on scrolling down the Interaction. But the CTI phone controller must be static and not scroll.


Error Messages



Not Applicable.


Steps to Reproduce



1. Login to the system and launch Interaction portal.
2. Open an interaction and login to CTI phone controller.
3. Scroll down the UI and observe that the CTI phone controller also scrolls.


Root Cause



An issue in the custom application code or rules cpm-overrides.
Developer has customized the CSS properties so that scroll bar is applied to the entire page including the CTI phone controll and Interaction header which is causing the scroll bar to appear for entire page.
The scroll should be applied for only member 360 form.

Overflow of the entire page body is set as below.


BODY.screen-layout-body {
  overflow-y:auto !important;
}

Resolution



Remove the following code:

BODY.screen-layout-body {
  overflow-y:auto !important;
}

Add the following code to get a scroll for member 360 view(Iframe body):

body.harnessBody{
overflow:auto !important;
}

Published January 31, 2016 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us