Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Custom control renders as readonly if edit mode is set to auto

SA-6052

Summary



If edit mode for a custom control is set to auto, the control renders in read only mode.

Error Messages



Not Applicable.


Steps to Reproduce



1. Create a custom link control and embed it in a section. Set the edit mode to auto.

2. Add a button at the bottom of the harness and call the section created in the previous step on click of the button.

3. At runtime, on clicking the button, the custom control gets rendered in readonly mode.


Root Cause



At the bottom of the harness, the dotted blue line area is reserved for buttons and is a readonly area.
 
When the user clicks the button in this area to load the section, the section and all the controls / components within it also get rendered in read only mode.
 
Since the custom control has its edit mode set to Auto, it inherits the read only mode from the section it is embedded in.



Resolution



The edit mode of the control needs to be explicitly set to "Editable".
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us