Support Article
Custom Desktop not loaded in Chrome
SA-7889
Summary
Issue-1: In FS6.8 BA with IE8, custom desktop is not loaded when you enter login credentials, instead, it displays a blank screen.
Issue-2: HomePage window for custom desktop does not get maximized in Chrome. The Homepage gets maximized in IE and on changing custom desktop.
Error Messages
Not Applicable
Steps to Reproduce
Log in to the application using BA with Chrome browser.
Root Cause
The root cause of this problem is defect/misconfiguration in the FS operating environment. Issue is not replicable in IE browser.
Resolution
For Issue-1: Provided modified version of custom desktop.jsp file having changes of OOTB destop.jsp from baAdvisorWeb folder location. Chrome desktop was loaded after removing the below piece of code from custom desktop.js doFormSubmit() method. This is an IE specific code.
var ua = window.navigator.userAgent
var msie = ua.indexOf ("MSIE ");
var browserVersion = window.navigator.userAgent.substring (msie+5, ua.indexOf (".", msie ));
Also, merged Chrome related code from baAdvisor/desktop.jsp
// Check for Browser Chrome, if so open in new window
<%
if ( request.getParameter("Chrome") != null && request.getParameter("Chrome").equalsIgnoreCase("False") )
{
%>
var targetId;
var sWindowFeatures = "status,menubar=false,resizable,top=10000";
...........
..........
For Issue-2: After applying the patch (HFix-903: Patch to Support IE11 and Chrome39 on FS6.8) using JSF2.1, the custom Homepage gets maximized.
Published January 31, 2016 - Updated October 8, 2020
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