Support Article
In custom mobile app, autocomplete shows top 8 results, not all
SA-32606
Summary
On custom mobile app, autocomplete sourced by data page is only showing 8 results. When the same autocomplete field is accessed on browser (mobile/desktop) shows all the results.
Error Messages
Not Applicable
Steps to Reproduce
Create autocomplete sourced from Data Page. Open on custom mobile app and search something that should display more than 8 results
Root Cause
This is an expected behavior of autocompletes. When we are using 'custom mobile app' to run the case, by default templating is enabled and the autocomplete automatically shows the non-grid (template) based results. So it will only show top 8 results as template based AC are configured to show only top 8 results to make it light weight. But if you run the same case in mobile browsers it will show the grid based autocomplete (non-template) with all the results as through mobile browsers we are able to send server requests.This was done to avoid scrolling in mobile devices since that would not be a good user experience. Also to show all the results will make the results very cluttered which we do not want for mobile devices. Autocomplete controls are just to provide suggestions.
Resolution
An enhancement request, FDBK-18042, has been created for consideration by Pega Product Management. The enhancement is targeted at making this behavior configurable for a hybrid client.
Published January 24, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.