Support Article
Data Type Import issue for user's non-default Access Group
Summary
Unable to complete the Import wizard on the Data Type landing page after a user switches from their default Access Group to another Access Group listed on their Operator ID. The user's default Access Group is under-privileged.
The batch Java threads, in the Log files, report an authorization failure message confirming that the child requestor does not have sufficient authorization to create or modify instances of the Data Type being imported.
Error Messages
Not Applicable
Steps to Reproduce
- Register a Data Type to run the Import wizard against it.
- Identify or create an Access Group (NONADMIN) that does not have Modify privileges on the class of the Data Type.
- Identify or create an Access Group (ADMIN) with Modify privileges on the class of the Data Type, with Designer Studio portal access, and with sufficient privileges to run the Data Type Import wizard.
- Create an Operator ID that has both NONADMIN and ADMIN on its Access Group list
- Set the NONADMIN Access Group to be the default Access Group and save the Operator ID
- Log in as the Operator ID (created in Steps 4 and 5). User is logged into the NONADMIN access group.
- Switch to the ADMIN access group.
- Open the Record viewer for the Data Type registered in Step 1.
- Run the Import wizard to ‘Add or update’ records from a CSV (the CSV to import can be as simple as 1 record). Accept the defaults until the auto-refreshing screen appears to display the progress of the import.
Root Cause
A defect in Pegasystems’ code or rules.
This is due to the pzImportRecordsWrapper activity orchestrating the import through a child requestor without including the parameters (listed in https://pdn.pega.com/support-articles/issue-child-requestor-access-group) on the parameter page to the queueBatchActivity call in the Java step. This results in the Import running from the user's default Access Group (non-Administrators) which is different to the Access Group the user switched-to to start the Import wizard (Administrators).
Resolution
Apply HFix-36510.Published November 2, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.