Support Article
Developer portal is not working after upgrading to IE 11
SA-8353
Summary
You are using PRPC 6.3 SP1 and have just upgraded to Internet Explorer 11. When you log in to the Developer portal, you see issues with the displayed portal and are not able to continue with work.
Error Messages
No error messages, only blank pop-up screens
Steps to Reproduce
You are using PRPC 6.3 SP1 with IE 11
Root Cause
The root cause of this problem is in a third-party product. Internet Explorer 11 was changed from prior versions and PRPC 6.3 SP1 was released prior to IE 11, so does not support it for the Developer portal out of the box.
Resolution
This issue is resolved through the following local change: Internet Explorer 11 can be run in compatibility mode for the Developer portal site and this avoids the issue of the changes within IE 11.
Please note that IE 11 has significant changes from earlier versions. The traditional and composite user portals can be addressed with hotfixes. However for the development portal, it is recommended that the browser be used in compatability mode.
This issue is further described on the PDN in this location: https://pdn.pega.com/user-interface/troubleshooting-ie10-and-ie11-ui-problems-fixed-by-prpc-5x-and-prpc-6x-hotfixes-for-ie5-quirks-mode
On user portals and IE 11:
https://pdn.pega.com/user-interface/troubleshooting-ie10-and-ie11-ui-problems-fixed-by-prpc-5x-and-prpc-6x-hotfixes-for-ie5-quirks-mode
On IE 11 support by older versions of PRPC:
https://pdn.pega.com/documents/platform-support-guide
Page 23.
Published June 12, 2015 - Updated October 8, 2020
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