Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Disable Page passivation does not work after change in setting



On disabling passivation by adding the below element in the prConfig.xml, all active pages and threads persist in the Pegadata.pr_page_store.

<env name="initialization/persistrequestor/usepagelevelpassivation"value="false"/>

Error Messages

Not Applicable

Steps to Reproduce

  1. Disable passivateRequestor setting.
  2. Add the below setting to prconfig on all the nodes.

    <env name="initialization/persistrequestor/usepagelevelpassivation" value="false" />
  3. Restart the system to clear cache.
  4. Truncate records parallely from the below tables.


  5. Restart the server.
After disabling page passivation setting,
  1. Log in to User portal.
  2. Open cases (pages or threads) in multiple tabs. Similar number of records are added to the table.

Root Cause

Passivation switch is deprecated.


Here's the explanation for the reported behavior:

The usepagelevelpassivation switch is deprecated in Pega 7.2.


Published November 29, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us