Support Article
Display of 0 values not allowed on the x-axis
SA-31401
Summary
Whenever a report has zero value at the starting or end of the X-axis of a chart , they are not displayed to the user.
Chart should display the count of resolved cases for last 7 days, for example: 24th November and 30th November, but only 5 days are displayed in the chart.
24th Nov and 30th Nov is not displayed as the count of resolved cases on these two dates are zero. Users want to view the 7days on the chart even if the count is 0 on any day.
Error Messages
Not Applicable
Steps to Reproduce
1. Create a section.
2. Drag a chart control.
3. Refer a report definition in the chart control. The report definition is to display count of resolved alerts in last 7 days. When the section is displayed to the user, the chart shows those days which have values other than 0. This happens only for the boundary dates. If the boundary dates have value 0, they are discarded from the report.
Root Cause
An issue with the user configuration. Users were sometimes able to view the date when there was no value for that date as they have configured the range to default.
Resolution
Perform the following local-change steps:
1. Configure range as "Reference Start value" and provide date range as Previous 7 days.
2. Create a TodayDate property.
3. Configure a declare expression on TodayDate property and set it to current DateTime(GMT) as shown below:

4. Refer that property in Date range start field under chart cell properties:

Published December 22, 2016 - Updated October 8, 2020
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