Support Article
DocuSign integration signed document is empty in Pega case
SA-75972
Summary
The DocuSign integration is configured on the Pega application. When opening a signed document which is attached to a work object by the DocuSign REST service, the document is an empty 0 KB file.
Error Messages
Failed to load PDF document
Steps to Reproduce
- Customize the below data transforms according to the application's Clipboard page structure:
– pySetEnvelopeCredentials
– pyPrepareNewEnvelope
– pyAssignRecipientsToEnvelope
- Create a work object.
- Open the email, sign the document, and submit it.
- Open the work object. The signed document must already be attached with the work object.
- Open the signed document. The document is empty and the Certificate of Completion document is also empty.
Root Cause
User was using Pega Cloud. The PegaRULES application by default was configured to use the pegacloudfilestorage repository to save attachments since it was a Cloud instance. The user built the application on the PegaRULES application and configured DocuSign on it. The DocuSignIntegration.pyConnect REST Service was not configured with the custom authentication, hence, it used the PegaRULES application default authentication. As a result, the attachments were attached to the pegacloudfilestorage repository instead of the custom application content storage, that is, Pega default database.
Resolution
Perform the following local-change such that attachments are stored in the Pega default database instead of pegacloudfilestorage repository:
Configure the custom authentication for the DocuSignIntegration.pyConnect REST service to use the custom application authentication.
Published August 15, 2019 - Updated December 2, 2021
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