Support Article
doFormSubmit displays a blank screen instead of Busy indicator
SA-103327
Summary
User clicks the Navigation menu (Actions>Save). However, a blank screen displays for a few seconds before the screen loads correctly. The Busy indicator is unavailable during this process.
This Save action uses a run script to invoke doFormSubmit and a custom activity.
Error Messages
Not Applicable
Steps to Reproduce
- Create a Navigation rule
- Invoke run script: doFormSubmit function with custom activity
- Create a section with Menu control
- Invoke the Navigation rule
Root Cause
A defect in Pegasystems’ code or rules. While processing Ajax call, the Busy indicator is getting hidden and a blank screen displays due to server latency.
Resolution
This issue is addressed in Pega 8.3.1 and 8.3.2.
Published June 10, 2020 - Updated December 2, 2021
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