Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

doFormSubmit displays a blank screen instead of Busy indicator

SA-103327

Summary

User clicks the Navigation menu (Actions>Save). However, a blank screen displays for a few seconds before the screen loads correctly. The Busy indicator is unavailable during this process.

This Save action uses a run script to invoke doFormSubmit and a custom activity.


Error Messages

Not Applicable


Steps to Reproduce

  1. Create a Navigation rule
  2. Invoke run script: doFormSubmit function with custom activity
  3. Create a section with Menu control
  4. Invoke the Navigation rule


Root Cause



A defect in Pegasystems’ code or rules. While processing Ajax call, the Busy indicator is getting hidden and a blank screen displays due to server latency.

Resolution



This issue is addressed in Pega 8.3.1 and 8.3.2.

 

 

Suggest Edit

Published June 10, 2020 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us