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Support Article

Double clicking on the left navigation item freezes the UI

SA-40384

Summary



User is having Pega Customer Service 7.22 with Pega 7.2.2.

When user logs in to the interaction portal (login as the CSR) and double clicks on the pulse the UI freezes.


Error Messages



Not Applicable

Steps to Reproduce



1. Login in to CRM application.
2. Launch Interaction portal.
3. On left navigation panel, double click on Tags and then double click Pulse.
4. Observe that screen gets hang and cursor keeps rotating for indefinite time, and notice system freezes.

Root Cause



A defect in Pegasystems’ code or rules:

The links in the left panel have action launch harness action.

When multiple links are clicked without giving time, some requests get canceled because the element which fired the request might not be present in the Document Object Model (DOM) anymore.

Resolution



Add below code in UserWorkForm, which would not fire the click on other elements if clicked until the previous request is finished:

<script>
$(document).ready(function() {
if (pega && pega.ui && pega.ui.busyIndicator) {
pega.ui.busyIndicator.prototype.show = function(B, D) {
if (this.busyIndTimeOut != null) {
clearTimeout(this.busyIndTimeOut)
}
var E = this;
this.busyManager = true;
this.createIndicatorImage();
if (!window.event || typeof(event) == "undefined") {
var A = null;
if (this.show.caller || typeof(this.show.caller) != "undefined") {
A = this.show.caller
}
if (A && A.arguments[0] && A.arguments[0].constructor && (window.Event == A.arguments[0].constructor || window.UIEvent == A.arguments[0].constructor)) {
event = A.arguments[0]
}
}
E.showInternal();
}
}
});
</script>

Published October 12, 2017 - Updated October 8, 2020

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