Support Article
E-mail campaign keeps hanging at "Running" Stage
SA-13498
Summary
E-mail campaigns remains at "Running" stage because somehow MD is unable to send all messages to e-mail server. Also, if campaign creates a new cycle after a day, both cycles seems to be running at dashboard.
It might be Idle connection. E-mail server admin reported that there are no problems on the e-mail server side about the speed of the process. They are not having queues for messages, they are being sent immediately.
All e-mail campaigns having this issue. They cant complete sending messages and somehow stops after a day. We might need a Netsession meeting for resolving the issue.Current e-mail sending rate is now about 5 e-mails per second. With the same Vantage settings, it was like 15 before.
Current Vantage parameters are :
VenvEmailBlockSize 150
VenvDefaultEmailServerMaxConnections 5
And also increased "Max Connections" value for each server to 5 on CMD Client.
Campaigns generally have html elements which have about 4 to 8 placeholders.
Attachments will be campaign logs, ps-ef output and e-mail process logs.
Error Messages
Not Applicable.
Steps to Reproduce
The steps to reproduce is not known.
Root Cause
Email campaigns generally used first and last name of the customer along with e-mail adress. In customer table, e-mail adress field was indexed but firstname and last name columns were not.
Resolution
Adding indexes to related columns solves the issue.
Tags:
Published August 28, 2015 - Updated October 8, 2020
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