Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Email body format not retained when auto reply is sent

SA-98556

Summary



While sending an auto-reply using the pxReply activity from the Interaction Portal or using Channel Auto Reply, the borders are missing for the table in the email body.


Error Messages



Not Applicable.


Steps to Reproduce

  1. Create a section with a table
  2. Add the section to Correspondence rule
  3. Send the correspondence using the pxReply activity


Root Cause



A third-party product issue. The issue is with Outlook which removed the added styles, class attributes, and inline styles. 

Resolution



Perform the following local-change: 
  1. Open the pyInvolved_pulseDiscussion Correspondence rule
  2. Click the Edit mode button and select source only
  3. Add the below code in the Correspondence rule:

    <style>
    table[class*="mcnCaptionBlock"] tbody[class*="mcnCaptionBlockOuter"] table tbody tr  th,
    table[class*="mcnCaptionBlock"] tbody[class*="mcnCaptionBlockOuter"] table tbody tr table[class*="mcnCaptionRightTextContentContainer"] table td {
        border:1px solid black;
    }    
    </style>


 

Published January 14, 2020 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us