Support Article
Email Listener does not forward unprocessed emails
SA-21699
Summary
Email Listener does not forward unprocessed messages. An exception appears in logs.
Error Messages
( services.email.EmailListener) ERROR EMAIL.Your_Listener.Listener - caught java.lang.NullPointerException when processing message number 0
java.lang.NullPointerException
at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.connectTransport(EmailListener.java:4740)
at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.sendAdminMessage(EmailListener.java:4913)
Steps to Reproduce
Configure Email listener with conditions given below:
- Select Forward unprocessed messages, and enter forwarding email address.
- Enter maximum email size in the Process tab.
- Send an email with size more than what is mentioned in Process tab for email listener.
Root Cause
A defect in Pegasystems’ code or rules. Pega code throws NullPointerException with dynamic system setting email/blockResponse as True when forwarding unprocessed emails to the configured email account.
Resolution
Perform the following local-change:
Set dynamic system setting email/blockResponse to False in Pega-IntSvcs, and restart the listener.
Published April 6, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.