Support Article
Email listener not working
SA-33662
Summary
User has created an email listener and a service email, which is referenced by the listener. The service email contains a service activity. It runs fine standalone, but the activity is not triggered from the email listener.
Error Messages
Not Applicable
Steps to Reproduce
Unknown
Root Cause
An issue in the custom application code or rules:
User did not email the correct email address. After modification, that email is not attached to the work object. The email is not attached because there is no code in the service activity to attach it to the work object.
Resolution
Perform the following local-change:
Email the correct email account, and call activity pyAttachApprovalEmail. This attaches the email to the work object.
Published February 27, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.