Support Article
Email listeners keep going to sleeping mode
SA-38630
Summary
Email Listener fails with an error in Pega log files and keeps going into sleeping mode with Pega 7.2.1.
Error Messages
2017-05-25 12:09:15,142 [ EMAIL-Thread-161] [ STANDARD] [ ] [ CECFW:01.04.01] (ed.pega_rules_businesscalendar) FATAL EMAIL.JWEmailListener.Listener|from( )|sub(FW: Quote )|Email|JWEmailSvcPkg|JW-FW-JWCECFW-Work-CS|CreateEmailInteraction|A7AEA1B409B5348726FA6BDB96D9D905A - The business calendar object could not be found
Steps to Reproduce
Not Applicable
Root Cause
This error normally occurs when Calendar for referred year does not exist in Pega.
Resolution
Refer to below PDN article to resolve the issue:
https://pdn.pega.com/community/pega-product-support/question/business-calendar-object-error
Published July 5, 2017 - Updated October 8, 2020
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