Skip to main content

Support Article

Empty date fields default to 01/01/1970

SA-38409

Summary



Default date value (01/01/1970) displays on submitting an empty date field.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create a service to input a date element and output a date as a response.
  2. Input a blank value in the date field.
  3. Run the service.



Root Cause



When the date is empty, the XML Stream rule generates a default date (epoch date); and the Service Response displays 1970-01-01.


Resolution

Perform the following local-change:
  1. Apply HFix-27413.
  2. For the XML Stream rule to return an empty date value, set the Dynamic System Settings (DSS) (disableEpochDate and disableEpochDateTime on Pega-IntegrationEngine) to True.
  3. Change the DateTime property to Date property.



 
Suggest Edit

Published November 29, 2018 - Updated October 8, 2020

Did you find this content helpful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Ready to crush complexity?

Experience the benefits of Pega Community when you log in.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us