Support Article
End users unable to schedule reports
SA-8538
Summary
Unable to schedule standard reports using end user IDs ( for example: manager and csr). This only works with developer credentials.
Error Messages
Not Applicable
Steps to Reproduce
- Log in to portal using an operator ID of the manager or CSR level.
- Click on the report browser tab.
- Right click on any report (or click on the gear icon), and the schedule button would be missing.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules. The logic to determine whether the user had the authority to schedule standard reports would only allow the option if the user had developer privileges (allow rule checkout enabled). It has been decided that this restriction should not exist. A change will be implemented such that any user who has the ability to run a report will be able to schedule it.
Resolution
This issue is scheduled to be resolved in Pega 7.1.8
Published June 12, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.