Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Error on clicking button to build PegaRULES in Index Management

SA-51884

Summary



Error occurs when clicking the button to build the PegaRULES index in the Index Management screen.


Error Messages



Rule index build failed. Failed: SOAP service failed

In PegaRULES log file:

ERROR Rule-Connect-SOAP.Data-RuleSearch.ConnectBuildIndex - Exception
com.pega.pegarules.pub.services.ResourceUnavailableException: SOAP service failed.



Steps to Reproduce

  1. Navigate to System Management Application (SMA) > Administration > Index Management
  2. Click the 'Build PegaRULES Index' button with the 'Build Index on remote node' option selected


Root Cause

An environment or third-party software issue. Firewalls in the environment stops the SMA from initiating a SOAP connection with the application server to call the rules to build the index.


Resolution



Perform the following local-change to build the index:
  1. Log in to Designer Studio
  2. Use the Search Landing Page > System > Settings > Search

 

Published July 23, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us