Support Article

Error during update regarding installed hotfixes

SA-31366

Summary



The Pega 7.2.0 update script fails with an error regarding installed hotfixes. 


Error Messages



BUILD FAILED
/Pega7.2.0/scripts/setupDatabase.xml:380: The following error occurred while executing this line:
/Pega7.2.0/scripts/setupDatabase.xml:1494: This update cannot be applied, the system contains hotfixes generated after this release was built.


Steps to Reproduce



Run the update script.


Root Cause



A defect or configuration issue in the operating environment. 

Resolution



Refer the below documentation regarding this message:

    https://pdn.pega.com/documents/pega-721-platform-update-guide

If the system contains hotfixes that are newer than the update you are attempting to apply, the update fails with the error “This update cannot be applied, the system contains hotfixes Use the force update option to bypass this error. Forcing an update by using arguments To force an update by using arguments:

​1. Verify the settings in the setupDatabase.properties file. For information about the properties, see Editing the setupDatabase.properties file on page 16.

2. At a command prompt, navigate to the Pega-image\scripts directory.

3. Run one of the following commands to force the update:
update.bat --force=true
update.sh --force true

 

Published December 13, 2016 - Updated December 19, 2016

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.