Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Error occurs on clicking Action twice

SA-74750

Summary



User opens a case. On click of actions, the names of flow actions display to trigger changes as per the configuration. Error occurs on clicking Action twice.


Error Messages

Either no actions are specified for this assignment or you do not have the permission to access any of them.


Steps to Reproduce

  1. Launch the Custom portal
  2. Open a case
  3. Click Action twice. Error displays


Root Cause



An issue in the custom application code or rules. On clicking a flow action name, the required screen loaded. When other actions were performed, the flow was disrupted and the newAssignPage was removed.

Resolution



Perform the following local-change to display busy indicator when an action is being processed such that other actions are not performed simultaneously:
  1. Add the below code to the UserWorkForm:
    <script>
    function setBusyIndicatorCustom(){
    pega.u.d.busyIndInterval = 0;
    pega.u.d.setBusyIndicator();
    }

     
  2. Add the Run script action with the "setBusyIndicatorCustom" function name on click event of the appropriate item in the navigation rule, initially before other actions



 

Published March 12, 2019 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us