Support Article
Error occurs on clicking Action twice
SA-74750
Summary
User opens a case. On click of actions, the names of flow actions display to trigger changes as per the configuration. Error occurs on clicking Action twice.
Error Messages
Either no actions are specified for this assignment or you do not have the permission to access any of them.
Steps to Reproduce
- Launch the Custom portal
- Open a case
- Click Action twice. Error displays
Root Cause
An issue in the custom application code or rules. On clicking a flow action name, the required screen loaded. When other actions were performed, the flow was disrupted and the newAssignPage was removed.
Resolution
Perform the following local-change to display busy indicator when an action is being processed such that other actions are not performed simultaneously:
- Add the below code to the UserWorkForm:
<script>
function setBusyIndicatorCustom(){
pega.u.d.busyIndInterval = 0;
pega.u.d.setBusyIndicator();
}
- Add the Run script action with the "setBusyIndicatorCustom" function name on click event of the appropriate item in the navigation rule, initially before other actions
Published March 12, 2019 - Updated December 2, 2021
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