Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Error occurs when deploying the EAR on jBoss EAP 7.1

SA-54004

Summary



Error generated in the JBOSS log when deploying the prpc_j2ee14_jboss7JBM.ear application. This occurs when setting up a new Pega 7.3.1 instance running on JBOSS EAP 7.1.

Refer to the Pega Platform Installation Guide to configure the Application server: https://community.pega.com/knowledgebase/documents/pega-731-platform-installation-guide-jboss-redhat-eap-and-oracle



Error Messages



Java.lang.IllegalArgumentException: VFS000023: Given parent (\"/content/prpc_j2ee14_jboss7JBM.ear/prweb.war\") is not an ancestor of this virtual file"},
"WFLYCTL0412: Required services that are not installed:" =>



Steps to Reproduce

  1. Install and configure a JBoss EAP 7.1 instance.
  2. Import prpc_j2ee14_jboss7JBM.ear.


Root Cause



Deployment displays exception on upgrade  to JBOSS EAP 7.1, The issue is related to JBoss.


Resolution



As a local change, update the Jboss-deployment-structure.xml file.

For more information, refer to the JBoss knowledge base article entitled 'Deployment throwing exception on upgrade to JBOSS EAP 7.1'.

Published December 30, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us