Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Error when accessing a node via SMA

SA-9605

Summary



Attempting to access a node via SMA results in an error.

Error Messages



Failed to get mbean name.
Caused by: java.lang.Exception: Failed to get mbean name. objName: com.pega.PegaRULES:cell=HSSOBPMTTHAPP01Node01Cell,id="59e51b8a23917a93e5892b309233998d",name=com.pega.pegarules.management.internal.DatabaseTableInfo,node=HSSOBPMTTHAPP01Node01,process=server1,type=enterprise
Exception occured trying to invoke the getter on the MBean
at com.pega.jmx.connection.managenodes.Node.getMBeanName(Node.java:217)
at com.pega.jmx.ui.action.AuthenticateAction.execute(AuthenticateAction.java:193)


Steps to Reproduce



1. Configure Node in SMA.
2. Try to connect to the node via SMA.


Root Cause



If WebSphere Application Server's Global/Administrative Security is enabled in any environment, the Local Connection option in SMA does not work as this cannot transmit admin credentials. If Administrative security is enabled, then, Remote Connection option has to be selected.

Here is brief explanation of two options:
  • Local Connection: Connects directly to the platform MBean server via java interface (does not travel over network). User can do this if SMA and PRPC have been deployed on the same server/running in the same JVM. Note: This cannot be used with WAS Administrative security enabled.
  • Remote Connection: Connects to WAS's MBean server using the WAS admin client. User needs to specify the SOAP port for WebSphere (this is not the port that PRServlet runs on) and the host name or IP Address of the node. This is the only the option that can be implemented with WAS Administrative security enabled.

Resolution



This issue is resolved by making the following change to the operating environment:

Use the Remote Connection in SMA Node configuration. User needs to specify the SOAP port for WebSphere (this is not the port that PRServlet runs on) and the host name or IP Address of the node. This is the only option with WAS Administrative security enabled.
Suggest Edit

Published June 12, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us