Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Error when clicking manage records and issue with indexes

SA-43719

Summary



Following is the configuration details:
Product Version: 12.0.5546.0
Product Name: SQL Server 2014
Product Level: SP2
Product Edition: Standard Edition (64-bit)
Product Update Level: CU5


User tried to re-create indexes on pr4_rule-vw table following the below steps:

a. Copy the SQL contents for all the indexes corresponds to above table.
b. Delete the indexes corresponds to above table.
c. Re-create the indexes by executing the SQL contents that is available from step 'a'.


User also tried to run sp_updatestats as below to improve the performance:

USE <Database name>;
GO
EXEC sp_updatestats;


Error Messages



Status fail
Message There has been an issue; please consult your system administrator
Operator ID [email protected]
Requestor ID H6B5936A93648A81F185A9DF08237B06E
Timestamp Mon Sep 04 14:57:08 MSK 2017
Engine Version PegaRULES 7.20 ML1 (coreAssemblyCached_721_916)


Also in log file i see the following error message:

01 Sep 2017 09:51:47,727 +03:00 [ttp-bio-8080-exec-70] [TABTHREAD3] [ ] [ KPIFW:01.01.01] (ngineinterface.service.HttpAPI) ERROR NAME.domain.country |111.11.11.111 person@email - 172.31.xx.yyy: com.pega.pegarules.pub.PRRuntimeError
com.pega.pegarules.pub.PRRuntimeError: PRRuntimeError
at com.pega.pegarules.session.internal.mgmt.base.ThreadRunner.runActivitiesAlt(ThreadRunner.java:712)
at com.pega.pegarules.session.internal.mgmt.PRThreadImpl.runActivitiesAlt(PRThreadImpl.java:467)
at com.pega.pegarules.session.internal.engineinterface.service.HttpAPI.runActivities(HttpAPI.java:3166)
at com.pega.pegarules.session.external.engineinterface.service.EngineAPI.processRequestInner(EngineAPI.java:390)
at sun.reflect.GeneratedMethodAccessor80.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.Thread.run(Thread.java:745)
Caused by: com.pega.pegarules.pub.runtime.IndeterminateConditionalException: There was a problem getting a list: код: 0 SQLState: HY008 Сообщение: The query has timed out.
at com.pega.pegarules.priv.FUAUtil.activityPreTranIndeterminateConditionalCheck(FUAUtil.java:442)
at com.pegarules.generated.model.ra_model_pzinitializedatatype_527ff2515647d90af1bcd04538e8e665.whenCondition_2(ra_model_pzinitializedatatype_527ff2515647d90af1bcd04538e8e665.java:479)
at com.pegarules.generated.model.ra_model_pzinitializedatatype_527ff2515647d90af1bcd04538e8e665.perform(ra_model_pzinitializedatatype_527ff2515647d90af1bcd04538e8e665.java:122)
at com.pega.pegarules.session.internal.mgmt.Executable.applyModel(Executable.java:4475)
at com.pega.pegarules.session.internal.mgmt.Executable.applyModel(Executable.java:4561)
at com.pegarules.generated.activity.ra_action_pzpreparenewlandingpage_6330a47b55495edaaf7e7b5013ed45de.step3_circum0(ra_action_pzpreparenewlandingpage_6330a47b55495edaaf7e7b5013ed45de.java:380)
at com.pegarules.generated.activity.ra_action_pzpreparenewlandingpage_6330a47b55495edaaf7e7b5013ed45de.perform(ra_action_pzpreparenewlandingpage_6330a47b55495edaaf7e7b5013ed45de.java:113)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3527)
at com.pega.pegarules.session.internal.mgmt.Executable.invokeActivity(Executable.java:10674)
at com.pegarules.generated.activity.ra_action_pxopenlandingpage_5428bf8b037f392531a7606f25485c67.step5_circum0(ra_action_pxopenlandingpage_5428bf8b037f392531a7606f25485c67.java:567)
at com.pegarules.generated.activity.ra_action_pxopenlandingpage_5428bf8b037f392531a7606f25485c67.perform(ra_action_pxopenlandingpage_5428bf8b037f392531a7606f25485c67.java:138)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3527)
at com.pega.pegarules.session.internal.mgmt.Executable.invokeActivity(Executable.java:10674)
at com.pegarules.generated.activity.ra_action_douiaction_98816bb549c28acd89176d91f202697a.step16_circum0(ra_action_douiaction_98816bb549c28acd89176d91f202697a.java:1767)
at com.pegarules.generated.activity.ra_action_douiaction_98816bb549c28acd89176d91f202697a.perform(ra_action_douiaction_98816bb549c28acd89176d91f202697a.java:321)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3527)
at com.pega.pegarules.session.internal.mgmt.base.ThreadRunner.runActivitiesAlt(ThreadRunner.java:646)
... 49 more


Steps to Reproduce



1. Open data explorer
2. Click on "Manage records" icon or on selected Data type. The error message appears.


Root Cause


A defect or configuration issue in the operating environment .

Microsoft SQL Server 2014 SP2 has cardinality issues and has recommendations for an upgrade to later versions.

The local-change suggested for Pega is to use SQL Server in a lower compatibility version (110) in order to stay in a supported platform stack.

Resolution



Here’s the explanation for the reported behavior:

Point the compatibility mode to SQL server 2012, that is,110.
Product Database Engine Version Compatibility Level Designation
SQL Server 2014 12 120
SQL Server 2012 11 110


Change the Compatibility Level using the following command to resolve the issue:

ALTER DATABASE pega
SET COMPATIBILITY_LEVEL = 110


Published January 5, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us