Support Article
Export to PDF takes about 7 minutes with direct node URL
SA-15693
Summary
Export to PDF takes approximately seven minutes with Pega 7.1.7.
Error Messages
Not Applicable
Steps to Reproduce
1. Open a report on User portal
2. Click 'Export to PDF'
Root Cause
A third-party product issue. The root cause of this problem is in a third-party product - pd4ml.jar library file, integrated with PRPC.
Due to the participation of HTML and CSS parsing during PDF generation, poor performance is observed intermittently when the skin gets picked from the application hierarchy. User was working with PRPC 6.x application skins in the portals. Hence, this intermittent performance issues with PDF generation is observed unless one is working on Pega 7.1.8, where one can ignore the formatting and application skin check.
Resolution
Below are the different resolution methods:
- Upgrade to Pega 7.1.8 to have a feature added newly in Report Definition rule, which will allow you to ‘Ignore formatting when exporting to PDF’ and ‘Ignore application skin when exporting to PDF’ from Data-access tab of your Report definition rule.
- Implement your own styles for reports which will support Pega 7.1.7 as suggested in this PDN article: https://pdn.pega.com/support-articles/export-pdf-reports-not-working-expected
- Additionally, you can restrict the Max number of rows count to export from ‘Data-access’ tab in your report definition rule.
Published January 31, 2016 - Updated October 8, 2020
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