Support Article
Failed to retrieve Rule-Service-SOAP instance PegaAES.Events
SA-16759
Summary
Recurring "Failed to retrieve Rule-Service-SOAP instance PegaAES.Events.logAlert using default rulesets" error message found in the application logs.
User Environment Details
- Pega 7.1.8
- AES 7.1.7
Error Messages
ERROR your_hostname.your_domain.org|127.0.0.1 - Failed to retrieve Rule-Service-SOAP instance PegaAES.Events.logAlert using default rulesets (Data-Admin-ServicePackage PegaAES doesn't exist)
com.pega.pegarules.pub.PRException: Failed to retrieve Rule-Service-SOAP instance PegaAES.Events.logAlert using default rulesets (Data-Admin-ServicePackage PegaAES doesn't exist)
Steps to Reproduce
Not applicable
Root Cause
A defect or configuration issue in the operating environment:
This issue usually occurs when the system is not setup as an AES server but some Pega node is sending to it SOAP requests misinterpreting it as one.
When the remote node send a SOAP request to the current PRPC isntance and the AES SOAP service is not present, the error is logged.
Resolution
Perform the following local-change:
- Identify the IP address of the remote node that is executing the SOAP request (127.0.0.1 in the former example)
- Connect to the node idenfied by the IP Address and either update the AES URL in the Pega Diagnostic Cloud Landing Page or update the prlogging.xml file with the correct endpoint of the AES Server.
Published January 31, 2016 - Updated October 8, 2020
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