Support Article
File listeners cannot be started from SMA
Summary
Unable to start file listeners from the System Management Application (SMA). After selecting a file listener from the SMA, and clicking the Start, the page refreshes indicating the command has been received. However, the file listener is not listed as running.
Error Messages
**Date and time**,112 [ FILE-Thread-1405] [ STANDARD] [ ] ( services.file.FileListener) ERROR File.YourFileListener administ[email protected] - Unexpected exception caught during processing.
java.lang.Exception: [/your/folder/path] does not exist.
at com.pega.pegarules.integration.engine.internal.services.file.FileListener.initialize(FileListener.java:1803)
at com.pega.pegarules.integration.engine.internal.services.file.FileListener.run_(FileListener.java:1878)
at com.pega.pegarules.integration.engine.internal.services.listener.ServiceListenerBaseImpl.run(ServiceListenerBaseImpl.java:448)
at java.lang.Thread.run(Thread.java:745)
Steps to Reproduce
- Navigate to the SMA Listener Management page.
- Attempt to start a file listener.
Root Cause
A defect or configuration issue in the operating environment.
Resolution
Ensure that the file path on the server is readable for the user who owns the java process for the application server. Check if the path permissions and structure are correct.
Published May 14, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.