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Support Article

Filter Condition in Report Definition OOTB not working

SA-40339

Summary



Out-of-the-box filters in a report definition do not display records during bulk processing, in the Manager portal.

Error Messages



Not Applicable


Steps to Reproduce

  1. Launch the Manager portal
  2. From the Operator menu, navigate to Bulk Actions > Select Process radio button
  3. Filter properties (such as, Case Type, Assigned To Operator, and Work Status) are displayed with the results
  4. Delete the Work status property row and click the Filter Cases button
  5. Remove and add the same filter value for the Assigned To Operator property
  6. Click the Filter Cases button


Root Cause



Records are not retrieved from the database and incorrect SQL query is generated when a new property is included in bulk processing, causing the filter property autocomplete to refresh the section and call the activity pzDefaultOperators. This activity sets pyUserIdentifier and pyLabel, used to retrieve records from the database, to "".




Resolution

Apply HFix-35324

Published September 11, 2017 - Updated October 8, 2020

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