Support Article
Filtering Clears when Select All and bulk transfer operation
SA-40394
Summary
Filtering Clears when Select All and bulk transfer operation
In bulk update/transfer screen, when doing the update/transfer by adding a filter to any of the column in the list and then clicking on the 'Select All' checkbox or completing the transfer or update operation clears the filter by refreshing the list
Error Messages
Not applicable
Steps to Reproduce
1. Go to Bulk Action area in Case Manager Portal and select ‘Process’ radio button, you will see an initial list of item below.
2. Now click on the Filter icon in any one of the column heading to do filtering.
3. Select a criteria and click on ‘Apply’, you will see that number in the “Select All # Results” Label does not reflect the current number of items in the list. after filtering the list have only 2 items, but the ‘Select All # Results’ Label does not reflect that.
4. After that if you select the check box ‘Select All # Results’ to select all the items of the filtered list, the list returns to the previous state and selects all the items that were present in the list before the filtering was done on the column.
Root Cause
Clicking on select all check box selecting all the cases not just filtered cases.
Resolution
Apply HFix-35428.
Published August 26, 2017 - Updated October 8, 2020
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