Support Article
"Frames" appended by JAWS when interaction is selected
SA-1904
Summary
Access Customer Process Manager (CPM) CSR Portal with JAWS enabled on the system and launch a new interaction from CPM CSR Portal.
Navigate through the screen using 'tab' key to select the interaction area. JAWS reads the type of interaction and appends 'Frame or Frames' after it.
For example, when phone call interaction is selected, JAWS reads "Phone call frame".
Error Messages
No error messages.
Steps to Reproduce
a) Access CPM application where JAWS is running.
b) Access CPM CSR Portal and launch a new interaction, for example, 'Phone Call'.
c) Navigate through the screen using 'tab' key to select the interaction area. While navigating, observe that JAWS reads out the links or frames selected.
d) JAWS reads the type of interaction and appends 'Frame or Frames' after it.
For example, when phone call interaction is selected, JAWS reads "Phone call frame".
Root Cause
A major component of the CPM portal screens are composed of non-autogenearted sections and accessibility, as a feature, is not tested in CPM 6.3 SP1.
Resolution
A major component of the CPM portal screens are composed of non-autogenearted sections and with the existing design in place, it is not possible to accommodate changes required to make CPM Portals as accessible. The current plan is to support accessibility needs for CPM 7.1.3 or 7.1 R3.
Published January 31, 2016 - Updated October 8, 2020
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