Support Article
FTSIncrementalIndexer agents fails frequently
SA-56091
Summary
FTSIncrementalIndexer agents fails frequently. As a result, the queue items are populated in the index table and the agent cannot process a large number of records.
Error Messages
Not Applicable
Steps to Reproduce
Create a work object. Check if the work object is available during search.
Root Cause
Indexing and search for classes is enabled for which search is not required. As a result, a large number of queue items are created and populated in the index table. The agent runs only on two to three nodes to manage the large number of requests. Although, the agent processes a maximum number of records, the new entries are greater than the number of records processed by the agent in the node.
Resolution
Perform the following local-change:
- Enable the 'Exclude this class from search' checkbox from the class definition for which search is not required
- Enable the agent on the other nodes. Therefore, the processing of the queue items is increased with the increase of the indexing/distributed/queue/maxrecords value which is defaulted to 500.
Published August 24, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.