Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

getPublicLinkURL function is returning blank value in Pega 7.1.7

SA-20625

Summary



User has upgraded from PRPC 5.5 to Pega 7.1.7. The getPublicLinkURL() function is returning a blank value after the upgrade to Pega 7.1.7.

Lower environments were not SSO enabled but only Production and UAT environments are SSO enabled. 

Error Messages



No Error Messages

Steps to Reproduce



Create new work-objects after Pega 7.1.7 upgarde
Send email correspondeces with links to access the work-object.

Root Cause



This behaviour was caused due to changes introduced in Pega 7.1.7 for Public Link URL. From this release onwards all users must use the Declare Page instead of the Data-Admin-System-Settings (DASS).

Resolution



Basically, , getPublicLinkURL() function is used by the Directed Web Access (DWA) feature. DWA enables external users that do not have a PRPC Operator ID to process an assignment in your application on a one-time basis. The URL you specify here is provided in an email to the external users to access PRPC and may identify a proxy server. 

By submitting the Public Link URL from the Resource URLs landing page instead of from DASS as mentioned above which resolved the issue.
Suggest Edit

Published March 16, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us