Support Article
Getting com.pega.pegarules.pub.database.LockGoneException
SA-9613
Summary
Users encounter multiple issues when working in their applications, including screen freezes, blank screens, and random errors in different screens.
Error Messages
javax.ejb.EJBException: nested exception is: com.pega.pegarules.pub.database.LockGoneException: Save, Delete or Commit has failed because lock is not held
Root Cause
CAVerticalLogTaskCompleted activity is configured to execute on close of the Process tab. This event-based asynchronous activity happens in parallel with the PRPC work item Close and Flow End calls. At the end of the flow or on close, PRPC releases the lock on the work page. (In the case of RunOnInteraction service processes, it releases the lock on the interaction page.)
The reported issue comes when the PRPC work item closes before the CAVerticalLogTaskCompleted activity is executed.
Resolution
Apply HFix-22015 for Customer Process Manager (CPM) 6.3 SP2.
Published June 15, 2016 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.