Support Article
The highest version of the Delegated rule does not open
SA-57341
Summary
After delegating a rule with 'Open the Highest Version', the highest version of the rule does not open when viewing the delegated rules in the portal.
Error Messages
Not Applicable.
Steps to Reproduce
- Create a rule in two different versions of the ruleset. For example, 02-01-02 and 02-01-05
- Delegate the rule in the 02-01-02 version
- Navigate to the portal and click the link of the name of the rule. The rule in 02-01-02 opens instead of the one in 02-01-05
Root Cause
An issue in the custom application code or rules.
The modification performed on Embed-System-User-MyRules.pyDelegatedRule resulted in the issue. It did not use Embed-System-User-MyRules.OpenDelegatedRules activity which opens the rule resolved instance of the rule.
Resolution
Perform the following local-change:Use the out-of-the-box Embed-System-User-MyRules.pyDelegatedRule section and Embed-System-User-MyRules.OpenDelegatedRules activity to open the rule.
Published July 23, 2018 - Updated October 8, 2020
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