Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

IAC Issue: Redirection appears to be in a loop ERROR

SA-11098

Summary



User is unable to access IAC gadget and faces redirect issue.

Error Messages



Redirection appears to be in a loop, terminating request: http://*.com/prweb/IAC/aOddnZhnFMl6vN9uhkDY-gjspzDvHMwv/!GCSOrigination_Web/$IAC14342628309

Steps to Reproduce



1. Create IAC gadget in Pega 7.1.8.
2. Access the IAC Gadget.


Root Cause



The root cause of this problem is a defect/misconfiguration in the operating environment.
In IAC Gateway application, host is configured with HTTP protocol. However, in Pega application, SetSecureCookie is set to true which causes the issue.

<env name="HTTP/SetSecureCookie" value="true" />)


Resolution



This issue is resolved through the following Local-change:

Set SetSecureCookie to false to resolve the issue.

OR

1. Create host name in IAC Gateway application with HTTPS protocol. 
2. Enable Secure Cookie in Gateway Setup settings page.
3. Use HTTPS as Gateway URL.

Published June 25, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us