Support Article
Improper font size when a email is sent from application
SA-6377
Summary
Users are using OOTB rich text editor for entering the email body content. They use templates for email body content in some cases and in few other cases they will add text in RTE directly at the end of templates and in other cases they wont use templates. Now if they enter some plain text in the Rich Text Editor, the font size of the content in the Editor seems to be looking same with the template included. But when the same email content is sent to an end user, the font size of the email content is improper. Not the same as seen in the Rich Text Editor.
Error Messages
Not Applicable
Steps to Reproduce
Use RTE to enter the body of the email and send an email from application to end users inbox and look for the font size.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules. The templates used while sending an email to end users, has one font style, and RTE used to edit the email body with templates, will have another font, default font of RTE for the edited text. Hence causing the issue.
Resolution
This issue is resolved through the following local change: To make the whole font consistent in the sent email, below code is added in an activity step before sending an email from the application.
Property-Set activity step: .pyBody is set to “<font size=2 face=sans-serif>” + .OriginalBody + “</font>” + .Signature
Published January 31, 2016 - Updated October 8, 2020
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