Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Intent task re-added on opening Interaction case each time

SA-80798

Summary



On reopening an Interaction case, an Intent task is added automatically.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create a case such that it is configured to auto-launch a task.
  2. Close and reopen the Interaction. The Intent task is relaunched.


Root Cause



A defect in Pegasystems’ code or rules.
Auto-launch must occur only when the Interaction is created and not when the interaction is opened each time.



Resolution



Apply HFix-51814.

Additionally, the two rules below do not save due to tight Validation rules after another hotfix made the reference in the Pages and Classes tab of 'D_Interaction[]' illegal.
  1. CPMLoadInteractionIntents
  2. CPMGetSuggestedIntents
Remove the square brackets in the custom version for the rules to save successfully. 

Published August 17, 2019 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us