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Support Article

Intent Tasks are not showing in interaction driver screen

SA-35849

Summary



When a same intent is launched multiple times and closing each intent by click cross mark (X) or cancel the intent, the behaviour is in consistent. The developer is not able to find the closed intents in the interaction driver.

Error Messages



Not Applicable


Steps to Reproduce

  1. Login with casysadmin/install
  2. Launch the CPMInteractionPortal
  3. Add an intent Ex:Address Change
  4. Add 4 intents one after the other
  5. Close each intent by clicking cross mark on left pan. One intent is left remaining with tick mark at last.
  6. Again launch 4 more intents.
  7. Again close each intent one by one from left pan. This time all intents are remaining the with tick mark.


Root Cause



In the activity CPMLoadIntentTask at Step 6 if the intent of same type is in progress it is not adding/restricting to the D_Interaction_Intents and on close of the intent we are not able to find in the UI in the Interaction Driver.

Resolution



Suggested user to remove Step 6 and Step 7 in the activity CPMLoadIntentTask.

Published April 7, 2017 - Updated December 2, 2021

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