Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Interaction Driver does not display on creating an interaction

SA-56415

Summary



On creating an Interaction in the CPMInteraction portal, the Interaction Driver does not display.


Error Messages



Not Applicable.


Steps to Reproduce

  1. Open the CPMInteraction portal
  2. Launch an Interaction


Root Cause



An issue in the custom application code or rules. The Perform harness was not present in the PegaCA-Work-Interaction-Call class (or some other class derived from PegaCA-Work-Interaction). The custom harness was derived from PegaCA-Work. As a result, a call was made to PegaCA-Work!pyAddRecentItems. This inserted a value of 'NONE' in D_CPMPortalContext.pyID resulting in errors.

Resolution



Perform the following local-change:

Revert to the correct class for the Perform Harness.



 

Published July 23, 2018 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us