Support Article
Interaction Driver does not display on creating an interaction
SA-56415
Summary
On creating an Interaction in the CPMInteraction portal, the Interaction Driver does not display.
Error Messages
Not Applicable.
Steps to Reproduce
- Open the CPMInteraction portal
- Launch an Interaction
Root Cause
An issue in the custom application code or rules. The Perform harness was not present in the PegaCA-Work-Interaction-Call class (or some other class derived from PegaCA-Work-Interaction). The custom harness was derived from PegaCA-Work. As a result, a call was made to PegaCA-Work!pyAddRecentItems. This inserted a value of 'NONE' in D_CPMPortalContext.pyID resulting in errors.
Resolution
Perform the following local-change:
Revert to the correct class for the Perform Harness.
Tags:
Published July 23, 2018 - Updated December 2, 2021
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