Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Interaction item not getting created via email

SA-9475

Summary



Application is designed in such a way that if an email is received to a particular email ID from outside, the listener calls an activity and creates a work item and assigns to a workbasket. The listener works fine but the workitem does not get created.

Error Messages



com.pega.pegarules.pub.PRRuntimeException: Error: You lack access required to execute RULE-OBJ-ACTIVITY

Steps to Reproduce



1. Create a listener.
2. Create an activity to be called as soon as an incoming email is received so that it creates an interaction item.


Root Cause



A privilege class in the activity is specified and this is causing the issue. 

Resolution



This issue is resolved through the following Local-change: 

Removing the privilege class information from the activity (under security tab) has resolved the issue. 

Published June 12, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us