Support Article
Issue with drag and drop in Case Manager portal
SA-13328
Summary
Alert message is displayed incorrectly when assignments are dragged and dropped from work list or work basket in Case Manager portal. The issue occurs when access of role to object is defined on Assign- Class with open instances as zero.
Error Messages
@hasMessage(TransferWorkPage) is null
Steps to Reproduce
1. Define Access of role to Object on Assign- Class and ensure have 0 on Open instances.
2. Map this to an access role.
3. Log in to application with some UserID who has this access role mapped to their access group.
Root Cause
A defect in Pegasystems’ code or rules pxTransferAssignment. In pxTransferAssignment activity, 9th step precondition checks @hasMessage(TransferWorkPage). As per the logic, the process jumps from 3rd step to 9th step directly.
In between this, TransferWorkPage is missing from clipboard which causes the issue in 9th step.
Resolution
Install HFix-23414. This modifies the 9th step precondition. First it will check whether that page is there and then verifies the content.
Published August 28, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.