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Support Article

Issue with focus on the Operator icon

SA-96662

Summary



Focus highlight is invisible on the Call icon on the portal. The icon is interpreted as text by the Screen Reader. Hence, the role of button (menu or dropdown) is not perceivable for the user.


Error Messages

Not Applicable


Steps to Reproduce

  1. Enable Accessibility
  2. Use the Tab key to navigate on Designer Studio or Interaction portal.


Root Cause



Background colour of icons must be customized. 

Resolution



Perform the following local-change: 
Add the below script to the UserWorkForm:

setTimeout(function() { 
     if(pega && pega.u && pega.u.d && pega.u.d.isAccessible) {
     
       
       var iconFocusStyleNode = document.createElement("style");
       iconFocusStyleNode.innerHTML = 'div.operatorIcon:focus-within{ background-color:yellow!important;}';
      
        document.head.appendChild(iconFocusStyleNode);
       
       
       
     }
   }, 500);

 

Note: The changes impact only the Accessibility users and the regular users who use the same application are not impacted.
 

 

Suggest Edit

Published January 2, 2020 - Updated December 2, 2021

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