Support Article
Issue with re-assigning 'Complaints' to users in Chordiant
SA-4655
Summary
Chordiant users are unable to reassign Complaints to other users. When they attempt this, a generic Error is displayed with a timestamp – this timestamp refers to the attached errors in the Chordiant logs. The specific exception occurring is:
IdNameNotFoundException: ID [jgoyen0811] for entity USER not found
IdNameNotFoundException: ID [skumar36] for entity USER not found
Affected users exist in Admin Manager and are active users of Chordiant.
Error Messages
[08/12/14 09:14:58:750 GMT] 00000053 SystemOut O <Mon Dec 08 09:14:58 GMT 2014> <1418030098750> <ERROR> <Thd=WebConta
iner : 0> <com.chordiant.userprofile.services.UserProfileServiceBase.processRequest()> <Exception occured <com.chordiant.
userprofile.exceptions.IdNameNotFoundException: ID [skumar36] for entity USER not found> >
[08/12/14 09:14:58:753 GMT] 00000053 SystemOut O <Mon Dec 08 09:14:58 GMT 2014> <1418030098753> <ERROR> <Thd=WebConta
iner : 0> <com.xxx.complaints.tasks.complaints.UpdateComplaint.generateError()> <ERROR ID: CRM1418030098753>
[08/12/14 09:14:58:754 GMT] 00000053 SystemOut O <Mon Dec 08 09:14:58 GMT 2014> <1418030098754> <ERROR> <Thd=WebConta
iner : 0> <com.xxx.complaints.tasks.complaints.UpdateComplaint.generateError()> <com.chordiant.userprofile.ejb.user.UserS
essionException
at com.chordiant.userprofile.ejb.user.client.UserSessionBeanClientAgent.getBaseModel(UserSessionBeanClientAgent.j
ava:337)
Steps to Reproduce
na
Root Cause
The root cause of this problem is caching issue. The number of UserProfile records in database were more than the default cache size.
Resolution
Increasing the DefaultCache size in cache.ccf file (from 10000 to 20000) resolved the reported behavior.
Published January 31, 2016 - Updated October 8, 2020
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