Support Article
Issue with Resolution stages in Pega 7.1.8
SA-15751
Summary
When the developer is resolving a case, the pending assignments of the related case are not deleted even when the 'delete assignments upon resolution' check box is selected on resolution stage.
Error Messages
Not Applicable.
Steps to Reproduce
1.Create a new case type, define the three stages Create, Open, Resolve.
2.Check the 'Run on re-entry' option for the Open step.
3.Create a case and proceed till Resolved Stage.
4.Do a Change stage to 'Open' Stage, observe that there exists an open assignment for 'Resolve' step.
5.Finish the assginment in Open stage and observe that the case moves to resolution stage, however it does not stop at the open assignment in the 'Resolve' stage and resolves the case by cleaning the assignments.
Root Cause
On checking the stage history for all the stages, the current stage has unfininshed processes and proceeding based on it. User used to check only for last stage is stage history. Changes are in RUF pzCheckForAndDoAutomaticStageTransition in WorkUtilities Library
Resolution
Apply HFix-24158 to resolves the issue.
Published January 31, 2016 - Updated October 8, 2020
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