Support Article
Issue with viewing dashboard
Summary
User adds two customized options to the Publish dashboard based on Access group. However, only the Admin is able to publish to other users. A user with a different role is unable to view the dashboard customized by Admin for that tole.
Error Messages
Not Applicable
Steps to Reproduce
- Launch the Manager portal
- Log in as Admin
- Click the Configure icon on the dashboard
- Customize the dashboard
- Publish to an Access group
Root Cause
The pyUserDashboardLoadList data transform creates an ordered list (most specific to least specific) of Publishing options. An entry must be added to the Pagelist. The pyOwnerType and pyOwner values must be set. When the user displays the Dashboard section, the back-end loads instances of System-User-Dashboard based on the order of the list and the first instance found is used for display.
The pyUserDashboardCanPublishFor When rule determines the Publishing permission (who is allowed to publish at a specific level). This When rule is also used to build the Publish menu when an end user edits a dashboard.
Resolution
Perform the following local-change:
Add a condition to the pyUserDashboardCanPublishFor When rule such that options are rendered in Publish based on it.
Published February 24, 2020 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.