Support Article
Issue with warranty framework when upgraded to 7.2
SA-21661
Summary
When the warranty version 7.11 is installed on the Pega 7.2, the Repair Order process in manufacturing layer is blocked. After a serial number is selected the corresponding warranty details are not populated.
Error Messages
The warranty details will not be populated on the right side
Steps to Reproduce
Login to the manufacturing system with login mfgdealer/install where the warranty 7.11 is installed on 7.2 warranty.
Initiate a new Repair order process.
Select a serial number
The warranty details will not be populated
Root Cause
A defect in Pegasystems’ code or rules
Resolution
Apply HFix-26930
Description of Changes
1. Passed parameter FirstStartDate to GetActiveWarranty Decision Tree rule and changed Top.FirstStartDate to Param.FirstStartDate.
2. Removed Refresh Condition on section include of WarrantyDetails in ProductInformation section
2. Removed Refresh Condition on section include of WarrantyDetails in ProductInformation section
Published April 1, 2016 - Updated December 2, 2021
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