Support Article
Launch Harness - New Document not behaving as expected
SA-20616
Summary
In Customer Process Manager(CPM) 7.1.4 , configuring 'Launch harness' with a "New Document" option, a new tab does not get created on the portal at runtime.
Error Messages
Not Applicable.
Steps to Reproduce
1. Add a new menu item under the "Operator" name.
2. Configure menu item to "Open a new harness" in a "New document".
Root Cause
For a harness to open in a new tab, the underlying layout should be tabbed. Out of the Box (OOTB) , CPMInteractionPortalWorkArea is not configured with a tabbed layout.
Resolution
CPMInteractionPortalWorkArea has been configured tabless, after careful consideration of various other CPM requirements. So the reported behavior is expected Out-of-the-box (OOTB).
As a local-change:
1. Add the menu item to the left navigation panel and model the custom harness like the other OOTB Harness like for example, PMPegaPulse.
2. Ensure that the section containing the menu items (CPMDasboardIncludes) is also part of the harness.
Published March 12, 2016 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.