Support Article
Layouts on accessible portal do not appear expanded by default
SA-8403
Summary
In the PRPC 6.2 SP2 application, when an accessible user logs into his portal, the layouts appear expanded by default. When migrating the same application to Pega 7.1.7, log in as an accessible user and the layouts appear collapsed instead of being expanded.
Error Messages
Not Applicable.
Steps to Reproduce
1. Create a portal with collapsible layouts in PRPC 6.2 SP2.
2. Verify that it appears expanded with the PegaWAI ruleset in the application stack.
3. Migrate this application to a Pega 7.1.7 system.
4. Test out the portal with the Pega 7 version of PegaWAI ruleset in place. Verfiy if the layouts are expanded by default.
Root Cause
When you were on PRPC 6.2 SP2, the layouts in your portal appeared auto-expanded by default. The behavior is due to the code implemented for layouts is not “complete” in terms of being accessibility friendly. They cannot be expanded by keyboard and are not screen reader friendly. Hence the layouts are kept as auto-expanded by default by design.
As a part of new development in Pega 7, layouts are updated to have expand/collapse functionality using keyboards in the accessibility mode. The screen reader can read out the relevant information about title of the layout and is able to expand or collapse action. The auto expand behavior is removed in PegaWAI:07-10-09 and this is an intentional design change.
Resolution
This issue is resolved through the following Local-change:
If you need to maintain PRPC 6.2 SP2 behavior where the layouts need to be auto-expanded by default, then you must ensure that the “Expanded on load” check is checked on each layout.
If you need the layout only expanded when you are using accessibility, then you must also use the “Expand When” feature that you can set on the layout.
Published January 31, 2016 - Updated October 8, 2020
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