Support Article

Login screen refreshes and user is returned to same login screen

SA-74574

Summary



When logging in to the system, the user is returned to the login screen without an error message.
On relogging in to the application, the same login screen displays. This occurs post refresh of the login page.



Error Messages



EXCP000100web_i-0a637960be6faeccdNANABQ2H36PTT64FK56PYDQ53VDTH17K82TVKANAPegaSamplenull6431a92eb843dd43193d0f3ad85a95bbN0BQ2H36PTT64FK56PYDQ53VDTH17K82TVKA5144http-apr-8080-exec-10ActivationThread15504747201613275
com.xxx.your_rules.data.internal.access.Openerabc-xx-prod.your_system.net|127.0.0.1*(Activation Requestor)NANANANANANANANANANANA*[MSG][ASTERISKASTERISKASTERISKASTERISKASTERISK Caught exception during open][STACK][com.pega.pegarules.pub.database.DatabaseException: Database-General There was a problem opening a database instance SYSTEM-REQUESTOR-CONTEXT _=__W ¿9KEBFGEW223HHK74KA 0 22021 ERROR: invalid bytes



Steps to Reproduce



Not Applicable


Root Cause



A defect in Pegasystems’ code or rules.

Pega Cryptography operations (Encryption and Decryption) were used to protect the RequestorID in the Pega Rules cookie. Therefore, the Pega operator was unable to login.
After a Pulse change of SystemCDK, decryption of cookie fails. The Pulse change moved the Encryption and Decryption process to an inconsistent state. CurrentSystemEncryptKeyIDHash still contained the old Cryptographic Development Kit (CDK) ID.


Resolution



This issue is scheduled to be resolved in an update release of Pega 8.1.4, Pega 8.2.1, Pega and 8.3.

As a local-change, after the Pulse change, set the ActiveKeyID and CurrentSystemEncryptKeyIDHash to null.

Published March 2, 2019 - Updated March 21, 2019

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